Would you like to react to this message? Create an account in a few clicks or log in to continue.

You are not connected. Please login or register

SimulIDE_0.4.15-SR1_Win64 escaping -libraries path

2 posters

Go down  Message [Page 1 of 1]

EmuMannen



Hi and thanks for sharing the SimulIDE software. It is my first time running it and I think I have found a bug (at least on the Windows platform).

Conditions:

  • Home directory on a network share
  • Home directory path containing white space

Result:

  • Arduino IDE will set the default Sketchbook location to a UNC path, e.g.:
    \\foo.bar.inter.net\Home\username\My Documents\Arduino
  • SimulIDE compile command will contain an unescaped path to Sketchbook libraries, e.g.:
    -libraries \\foo.bar.inter.net\Home\username\My Documents\Arduino/libraries

Behavior:

  • SimulIDE will compile and report: SUCCESS!!! Compilation Ok
  • No hex file is produced
  • SimulIDE UpLoad will fail with error dialog about hex file not found

Workaround:

  1. Cut and paste SimulIDE compile command
  2. Manually escape -libraries path, e.g.:
    -libraries "\\foo.bar.inter.net\Home\username\My Documents\Arduino/libraries"
  3. Run escaped command from command prompt (will produce hex file)
  4. UpLoad now works

Or

  1. Move Sketchbook location to a local path without white space
  2. Change Sketchbook location (Arduino IDE>File>Preferences>Settings>Sketchbook location) to new path
  3. Restart SimulIDE and recompile (will produce hex file)
  4. UpLoad now works

Verification:

  • Cut and paste unescaped compile command from SimulIDE and run it from a command prompt (compile will fail with error message: Parameter 'fqbn' is mandatory ...)
  • Manually escape -libraries path and rerun the same compile command from a command prompt (compile will succeed)

arcachofo

arcachofo

Hi.

I think that issue is already solved.

Thanks for reporting.

Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum