Would you like to react to this message? Create an account in a few clicks or log in to continue.

You are not connected. Please login or register

simulide_1.0.0-RC1 ASSERT "index out of range"

2 posters

Go down  Message [Page 1 of 1]


Circuit Loaded: ~/..... /share/simulide/data/ICs/74HC02/74HC00.simu
Circuit Loaded and opening the properties of the elements causes the program to crash. I have not checked all the files in the directory.

74HC00.simu - ASSERT
74HC02.simu - ASSERT
74HC04.simu - ASSERT

Fatal: ASSERT failure in QList<T>::at: "index out of range", file /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h, line 544 (/usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:544, )
74HC08.simu - OK! Everything is fine in this file ...

Thanks for your work !

Last edited by arcachofo on Wed Jan 05, 2022 11:14 pm; edited 2 times in total (Reason for editing : Mark as solved (green color))



Thank you very much for reporting.
I will have a look.

Last edited by arcachofo on Wed Jan 05, 2022 9:38 pm; edited 2 times in total



I can't reproduce this issue.

It is probably already solved.
I leave it as unsolved until we have confirmation it is solved.


Thanks. I checked in version SimulIDE_1.0.0-R779 available on the "https://launchpad.net/" that this problem no longer exists.
Although, perhaps, the revision number R779 in the window title is also a bug. Smile
Next time I will collect a fresh version of the application.

arcachofo likes this post

Sponsored content

Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum