Would you like to react to this message? Create an account in a few clicks or log in to continue.

You are not connected. Please login or register

Arduino Tool Path on a Mac

2 posters

Go down  Message [Page 1 of 1]

1Arduino Tool Path on a Mac Empty Arduino Tool Path on a Mac Wed May 17, 2023 4:34 am


Having issues getting the standard Arduino Blink.ino to compile. Get output as follows:

Arduino     : Executable not found
     : Check that Tool Path is correct

Attempted to set the compiler path to the following with all not working:
- /Applications/Arduino\ IDE.app
- /Users/myusername/Library/Arduino15/packages/arduino/hardware/avr/1.8.6
- /Applications/ArduinoIDE.app/Contents/MacOS/Arduino\ IDE

Tried using SimulIDE 1 and 0.4.15 with Arduino IDE 2.1.0 on a MacOS 10.14.6 and MacOS 12.6.3 on Intel Macs. Have not got access to any of the newer M1 or M2 macs.

Thanks for any help. Really would like to use SimulIDE.

2Arduino Tool Path on a Mac Empty Solved Sat May 20, 2023 5:47 pm


I worked out the path myself. The tool path needs to be to the Java folder within the Arduino.app (1.8.19).

So manually enter the Tool Path to be:

Very Happy

3Arduino Tool Path on a Mac Empty Re: Arduino Tool Path on a Mac Sun May 21, 2023 8:09 pm



Thanks for the solution, I was scratching my head...

glyn likes this post

Sponsored content

Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum